Fixing the error: "Cannot find variant"

Last updated: August 7, 2025

Sometimes it is possible to see an error message from Shopify when you're being redirected from a landing page or a gifting link to checkout.

The "Cannot find variant" error comes from Shopify, not Superfiliate.

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Cause

This typically means the product is not active or not published to the "Online store" sales channel in Shopify, which doesn't allow Shopify to redirect the product to checkout

How to fix

  1. Make sure to set the product as "Active"

  2. Go to the product in your Shopify admin.

  3. Scroll to the "Sales channels and apps" section.

  4. Click "Manage".

  5. Make sure "Online store" is selected.

  6. Save the changes.

Once the product is published to the Online store, the error should go away. If you don't want the SKU to show up on your website, you can simply not add it to any collections